New to set up. Anyone able to help?

I’m at the section where I need to edit the .json and .yaml files. I have notepad++. How do I edit it on notepad++ and which lines do I edit? I’ve never used notepad++ before.

For .json do I only add my rpc mainnet on lines 10,13 and 16?

For .yaml do I only add my Ip? instructions say line 51 and 61? I only see it on 61. 51 says secrets?

Do you still need help?

In ‘Server/docker-compose.yaml’ file, you have to replace line 61 with your IP. The only thing to edit in that file is just one line.

In ‘Server/gatewayConfig.json’ file, replace line 10, 13, and 16 with your mainnet rpc.

In ‘Client/gatewayConfig.json’ file, replace line 2 with your signer. Replace line 13 with your mainnet rpc. The last thing to do is replace line 14 with your ethereum wallet’s private key.

1 Like

Yes! Thank you for responding! I was able to complete all the steps but I keep getting an error. Shown on the attached.

1 Like

The messages you posted are the messages I am also receiving during mining. There doesn’t seem to be a big problem.

Oh ok great! Thank you! How often are you mining a block?

Due to the soared mining difficulty, it is difficult to mine one or no blocks per day. I think it is a temporal situation and it will get stable when Mainnet 2.0 comes out. One block gives you 28 $CTC.

Thank you so much for responding and helping me out!


are these errors bad or normal?

I’m seeing this message for the first time, and it seems like the peer is in a bad state or something is wrong. Have you tried restarting docker?

No I will try that now.


It looks like you need to check if the snapshot is unpacked properly.

I got 187G from the command below.

docker exec sawtooth-validator-default du -sh /var/lib/sawtooth

Please check how big your snapshot is.

Thank you for replying!! I ran it and only got 144k. What should I do next?

This is the latest snapshot link.

Please refer the mining manual below.

I will try first thing in the morning. Thank you again for your response!

Just for your information.
It will take so much time to download snapshot file. It’s almost 90GB.
It’s better to start downloading it early.

1 Like

Ok thanks for the advise I’ll start the download now.

1 Like

on step 6 what do I change on this command $ sudo tar xzvf /ccSnapshot-2021.10.16_961837.tar.gz --directory /host/var/lib/docker/volumes/server_validator-block-volume/
I am getting this error /bin/sh: 1: $: not found

Could you show me the screen shot of error message?