I have a suggestion after reviewing the scripts added this time such as start_creditcoin.sh

sudo apt-get -y remove docker docker-engine docker.io containerd runc

sudo apt-get update
sudo apt-get -y install \
  apt-transport-https \
  ca-certificates \
  curl \
  gnupg-agent \

curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo apt-key add -
sudo apt-key fingerprint 0EBFCD88

sudo add-apt-repository \
   "deb [arch=amd64] https://download.docker.com/linux/ubuntu \
   $(lsb_release -cs) \

sudo apt-get update
sudo apt-get -y install docker-ce docker-ce-cli containerd.io

sudo curl -L "https://github.com/docker/compose/releases/download/1.26.2/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose

sudo chmod +x /usr/local/bin/docker-compose

sudo ln -s /usr/local/bin/docker-compose /usr/bin/docker-compose

How about using this script to install Docker+docker-compose?

Because I run the existing strat_creditcoin.sh to install docker, I get a docker serivce error message. It seems that the installation did not work well just by running the script.


yes | sudo ufw enable
sudo ufw allow 22/tcp    # for SSH # AWS Connection Error
sudo ufw allow 4004/tcp
sudo ufw allow 8008/tcp
sudo ufw allow 8800/tcp
sudo ufw allow 55555/tcp

In the case of consensus.sh, it would be good to use this part and put the code that opens the port according to the conditions.

I ran upgrade_creditcoin_node.sh to test rtorrent. The download speed was from 1.5MB/s to 7MB/s, and the average speed of 3-5MB/s was guaranteed.

It depends on the network situation, but it would be nice to think that it will be received within 2 hours.

However, when I run upgrade_creditcoin_node.sh and install without rtorrent, an error message stating that there is no dpkg appeared. However, even though this message appeared, I ran upgrade_creditcoin_node.sh again, and rtorrent worked normally and the download started.

In the case of install_apt_packages.sh, only the following message is displayed. Is it normal?


The rest of the features that I haven’t mentioned else work well.

In the case of upgrade~~.sh, it was confirmed that the restart~~ function part below does not work due to rtorrent execution. If there is a downloaded snapshot file, it seems that the conditional statement should be written by skipping the downloading part.

And even though the capacity is sufficient, a message indicating that there is no capacity appears and processing is not possible. It seems that the partial conditional statement needs to be changed.


Even if the capacity problem is solved, the following problem occurs, but changing the command seems good.

sudo tar xzvf creditcoin-block-volume.tar.gz -C /var/lib/docker/volumes/server_validator-block-volume/

I recommend the above command.

it seems that there’s node_sanity.sh path problem.

The presence of this line will remove the .last_block_tip. If I remove this, the next time I run sh, the .last_block_tip is missing, so the cat $CREDITCOIN_HOME/.last_block_tip will not contain nulls? So, when comparing block_tip and previous_block_tip, I think the unary operator expected error appears.

I think I need to copy the 32nd line below the 27th line and leave the .last_block_tip file.

above, that’s recent my logs.