Crontab @reboot issue

My server needs about 1 minute to activate the network after booting.

Probably for the security of the network switch.
(Spanning Tree Protocol??? The cause is unknown.)

Depending on the “crontab @Reboot” setting, the “start_creditcoin.sh” script will be executed after a reboot.

However, it is not executed correctly and an error log is generated in the “start_crontab.log” file.

Unable to query public IP address.

Are you planning to use “systemctl” instead of “crontab @reboot”?
(network-online.target)

This article was written with Google Translator.

It seems that the return value is 0 when you curl https://ifconfig.me.

After booting, wait for a while and the network will be enabled.
It doesn’t matter if you manually run the mining program after the network is activated.

Currently my problem is that crontab starts without waiting time right after booting.

Is it right to repair my server?

How many minutes does it take for you to set up your network? Put the command to sleep in crontab @reboot.

ex)

sleep 300; ~/strat_~~.sh

Yes, the query curl https://ifconfig.me occasionally fails at random times; it’s not related to crontab @reboot . The problem may be caused by incompatible TLS handshaking between client and server. This website works fine with curl:
checkip.amazonaws.com

You can also manually run the script ‘start_creditcoin.sh’ . Note that it checks the speed of your host machine using an OpenSSL SHA-256 speed test. Slow machines don’t operate Creditcoin well with Validator option
–maximum-peer-connectivity 5

I’m not sure about the reliability, but there are alternative sites.

https://ifconfig.co

It is possible to check if the 8800 port of the mining computer is open.

https://ifconfig.co/port/8800
curl --ipv4 ifconfig.co/port/8800

The source code is on github. If necessary, you can also provide service yourself.

FAQ

Is automated use of this service permitted?

Yes, as long as the rate limit is respected. The rate limit is in place to ensure a fair service for all.

Please limit automated requests to 1 request per minute . No guarantee is made for requests that exceed this limit. They may be rate-limited, with a 429 status code, or dropped entirely.